What’s Vulnerable › Vulnerabilities
CVE-2026-93605: vm2 NodeVM before 3.12.1 Remote Code Execution via child_process
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-18 · updated 2026-09-21
- Weakness: CWE-693
Description
vm2 NodeVM versions before 3.12.1 contain a sandbox escape vulnerability where the DANGEROUS_BUILTINS denylist omits child_process despite blocking other host-spawning modules. Attackers can require child_process and execute arbitrary commands on the host system when NodeVM is configured with builtin:['*'] or explicit child_process allowance.
Affected products
- patriksimek vm2: before 3.12.1 — fixed in 3.12.1
How to fix
Upgrade to a fixed version: patriksimek vm2 3.12.1. Check the vendor advisory for mitigations.
References
- https://github.com/patriksimek/vm2/security/advisories/GHSA-pq68-rvw4-xp4r
- https://www.vulncheck.com/advisories/vm2-nodevm-before-3.12.1-remote-code-execution-via-child-process
Get alerted when CVE-2026-93605 or the next vulnerability affects your stack