What’s Vulnerable › Vulnerabilities
CVE-2026-93658: uutils coreutils 0.0.18 before 0.10.0 Privilege Escalation via setuid
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-18 · updated 2026-09-22
- Weakness: CWE-281
Description
uutils coreutils versions before 0.10.0 apply setuid or setgid mode to install destinations before finalizing ownership changes, allowing privileged users to leave setuid executables owned by the privileged invoker when ownership changes fail. Attackers can execute leftover setuid files with elevated privileges when ownership change operations fail on capability-restricted systems.
Affected products
- Uutils coreutils: from 0.0.18 before 0.10.0 — fixed in 0.10.0
How to fix
Upgrade to a fixed version: Uutils coreutils 0.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/uutils/coreutils
- https://github.com/uutils/coreutils/blob/0.9.0/src/uu/install/src/install.rs
- https://github.com/uutils/coreutils/commit/7c87ab04fee8e52d989fb2625568a3eeda1b1f55
- https://github.com/uutils/coreutils/pull/13629
- https://github.com/uutils/coreutils/security/advisories/GHSA-cgg3-923w-v53m
- https://www.vulncheck.com/advisories/uutils-coreutils-0.0.18-before-0.10.0-privilege-escalation-via-setuid
- https://github.com/uutils/coreutils/security/advisories/GHSA-cgg3-923w-v53m
Get alerted when CVE-2026-93658 or the next vulnerability affects your stack