What’s Vulnerable › Vulnerabilities
CVE-2026-93684: Apache Impala: Stored XSS in Impala query plans
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-07
- Weakness: CWE-79
Description
An SQL user using Impala up to and including version 4.5.2 with only SELECT permission can put JavaScript in a table alias and make it run in another user's browser when that user opens the query plan in Impala's Web UI. This is stored XSS (CWE-79). Users are recommended to upgrade to version 4.5.3.
Affected products
- Apache Software Foundation Apache Impala: from 2.7.0 through 4.5.2
References
- https://lists.apache.org/thread.html/qxjj5n3vsttxbvq2n75xcy2qcrhtxowx
- http://www.openwall.com/lists/oss-security/2026/10/07/21
Get alerted when CVE-2026-93684 or the next vulnerability affects your stack