What’s Vulnerable › Vulnerabilities
CVE-2026-93759: Server-side JavaScript injection via string query criteria bypassing the strict operator allowlist
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-18 · updated 2026-09-24
- Weakness: CWE-94
Description
Mongoid does not neutralize a string-typed query criterion supplied to its query builder, and instead passes it to the database as a server-side JavaScript expression. An unauthenticated party able to influence the value an application supplies as a query argument may cause code of their choosing to be evaluated by the database engine. This may result in unintended disclosure of stored field values, unintended selection of documents for application-initiated writes, and reduced database performance.
Affected products
- MongoDB Inc. Mongoid: from 8.0.0 before 8.0.13; from 8.1.0 before 8.1.13; from 9.0.0 before 9.0.12; 9.1.0 — fixed in 8.0.13, 8.1.13, 9.0.12
How to fix
Upgrade to a fixed version: MongoDB Inc. Mongoid 8.0.13, 8.1.13, 9.0.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-93759 or the next vulnerability affects your stack