What’s Vulnerable › Vulnerabilities
CVE-2026-93894
- Severity: low (CVSS 2.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-18 · updated 2026-09-22
- Weakness: CWE-787
Description
In Vinyl Cache before 9.0,2, workspace buffer overflow vulnerability was found in the .upper() and .lower() string type methods of VCL. This can be used as a remote denial of service (DoS) vector to make the child process segfault or assert, and then restart. Effectively exploiting this vulnerability requires prior knowledge about the VCL in use and the ability to craft a request that contains a string that is long enough to fill the remaining workspace at the call site while staying under the different request size limits (http_req_size, http_req_hdr_len, etc.).
Affected products
- varnish-software Varnish Cache: before 9.0.2; from 9.0.0 before 9.0.4; from 6.3.0 through 8.0.2 — fixed in 9.0.2, 9.0.4
How to fix
Upgrade to a fixed version: varnish-software Varnish Cache 9.0.2, 9.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-93894 or the next vulnerability affects your stack