What’s Vulnerable › Vulnerabilities
CVE-2026-93952: Arista VeloCloud Orchestrator Improper Input Validation Vulnerability
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-09-22
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-22 · updated 2026-09-23
- Weakness: CWE-20
Description
VeloCloud Orchestrator (VCO) on-prem has a security issue where this issue may allow a remote attacker to access privileged internal functionality and impact the VCO host. Successful exploitation may compromise the confidentiality, integrity, and availability of the orchestrator and data managed by the orchestrator. Hosted, including Dedicated, versions of VCO were impacted and have already been patched.
Affected products
- Arista Networks VeloCloud Orchestrator On-Prem: from 5.2.0 before 5.2.3.16; from 6.1.0 through 6.1.3.7; from 6.4.0 before 6.4.2.8; from 7.0.0 through 7.0.0.2 — fixed in 5.2.3.16, 6.4.2.8
How to fix
Upgrade to a fixed version: Arista Networks VeloCloud Orchestrator On-Prem 5.2.3.16, 6.4.2.8. Check the vendor advisory for mitigations.
References
- https://www.arista.com/en/support/advisories-notices/security-advisory/24765-security-advisory-0183
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-93952
Get alerted when CVE-2026-93952 or the next vulnerability affects your stack