What’s Vulnerable › Vulnerabilities
CVE-2026-93990: Expat before 2.8.5 Malformed UTF-16 Acceptance via Unchecked Surrogate
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-19 · updated 2026-09-28
- Weakness: CWE-176
Description
Expat before 2.8.5 fails to validate that a high surrogate in UTF-16 input is followed by a low surrogate, allowing malformed UTF-16 sequences to be accepted. Attackers can supply UTF-16 encoded XML containing lone high surrogates that consume the following code unit, causing Expat to pass unpaired surrogates to applications built with XML_UNICODE and to silently replace input characters in other builds.
Affected products
- libexpat: before 2.8.5 — fixed in 2.8.5
How to fix
Upgrade to a fixed version: libexpat 2.8.5. Check the vendor advisory for mitigations.
References
- https://blog.hartwork.org/posts/expat-2-8-5-released/
- https://github.com/libexpat/libexpat
- https://github.com/libexpat/libexpat/commit/ff6e1d7e750bbe245178f51a47a965dc8342861a
- https://github.com/libexpat/libexpat/pull/1282
- https://github.com/libexpat/libexpat/releases/tag/R_2_8_5
- https://www.vulncheck.com/advisories/expat-through-2.8.4-malformed-utf-16-acceptance-via-unchecked-surrogate
Get alerted when CVE-2026-93990 or the next vulnerability affects your stack