What’s Vulnerable › Vulnerabilities
CVE-2026-94056
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-19 · updated 2026-09-24
- Weakness: CWE-908
Description
Exim before 4.100.1, when Proxy-Protocol is used with an attacker-controlled proxy, allows attackers to read certain uninitialized data from stack memory.
Affected products
- Exim: before 4.100.1 — fixed in 4.100.1
How to fix
Upgrade to a fixed version: Exim 4.100.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-94056 or the next vulnerability affects your stack