What’s Vulnerable › Vulnerabilities
CVE-2026-94197: NGINX Ingress Controller vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-15
- Weakness: CWE-290
Description
An authentication and authorization bypass vulnerability exists in F5 NGINX Kubernetes Ingress Controller (NIC) when configured with the `ExternalAuth` policy or Ingress external authentication. Client-supplied X-Forwarded-Prefix, X-Forwarded-URI, X-Original-URI, and X-Forwarded-Method routing and method headers are forwarded unsanitized into the internal authentication subrequest (handled by the NGINX auth_request directive). As a result, an unauthenticated, remote attacker may spoof request attributes evaluated by the external authentication provider. Impact: This vulnerability may allow remote attackers unauthenticated access to protected paths. There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Ingress Controller: from 5.5.0 before 5.7.0 — fixed in 5.7.0
How to fix
Upgrade to a fixed version: F5 NGINX Ingress Controller 5.7.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-94197 or the next vulnerability affects your stack