What’s Vulnerable › Vulnerabilities

CVE-2026-94212: Apache APISIX: unauthenticated impersonation issue in saml-auth

Description

Improper verification of cryptographic signature vulnerability in Apache APISIX. Any unauthenticated attacker could impersonate any user on every route protected by the saml-auth plugin under default configuration. This issue affects Apache APISIX: from 3.17.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.

Affected products

References

Get alerted when CVE-2026-94212 or the next vulnerability affects your stack