What’s Vulnerable › Vulnerabilities

CVE-2026-94220: Apache APISIX: session fixation issue in feishu-auth and dingtalk-auth plugin

Description

Cross-Site request forgery (CSRF) vulnerability in feishu-auth and dingtalk-auth plugins in Apache APISIX. An attacker who can get a user to click a crafted link may cause that user's browser session on a protected route to be established under the attacker's identity instead of their own. Any work the user then performs in that session, including uploads, form submissions, and account bindings, lands in the attacker's account. This issue affects Apache APISIX: from 3.17.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.

Affected products

References

Get alerted when CVE-2026-94220 or the next vulnerability affects your stack