What’s Vulnerable › Vulnerabilities
CVE-2026-94238: Loco Translate < 2.8.9 - Translator+ Limited File Read via 'path' Parameter
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-03 · updated 2026-10-06
- Weakness: CWE-22
Description
The Loco Translate WordPress plugin before 2.8.9 does not restrict which file paths its translation file routes will read, allowing users granted the Loco Translate WordPress plugin before 2.8.9's translator capability to retrieve the contents of files of certain types from anywhere on the server, including outside the web root.
Affected products
- Loco Translate: before 2.8.9 — fixed in 2.8.9
How to fix
Upgrade to a fixed version: Loco Translate 2.8.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-94238 or the next vulnerability affects your stack