What’s Vulnerable › Vulnerabilities
CVE-2026-94239: Loco Translate < 2.8.9 - Translator+ Stored XSS via Bundle Configuration
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-03 · updated 2026-10-06
- Weakness: CWE-79
Description
The Loco Translate WordPress plugin before 2.8.9 does not sanitise and escape some bundle configuration values before outputting them back in an admin page, allowing users with the translator capability and above to perform Stored Cross-Site Scripting attacks against high privilege users such as administrators.
Affected products
- Loco Translate: before 2.8.9 — fixed in 2.8.9
How to fix
Upgrade to a fixed version: Loco Translate 2.8.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-94239 or the next vulnerability affects your stack