What’s Vulnerable › Vulnerabilities
CVE-2026-94244: Wallet System for WooCommerce < 2.8.0 - Subscriber+ Store-Wide Wallet Transaction Disclosure via Export
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-08
- Weakness: CWE-200
Description
The Wallet System for WooCommerce WordPress plugin before 2.8.0 does not perform any capability check, and relies on a token any authenticated user can obtain from a front-end page, before generating a report containing every customer's wallet transaction history, allowing any authenticated user, such as a subscriber, to disclose all users' names, email addresses, roles, transaction amounts, payment methods and dates.
Affected products
- Wallet System for WooCommerce: before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: Wallet System for WooCommerce 2.8.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-94244 or the next vulnerability affects your stack