What’s Vulnerable › Vulnerabilities
CVE-2026-94245: Wallet System for WooCommerce 2.0.0 - 2.7.10 - Subscriber+ Arbitrary Wallet Balance Theft via IDOR
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-08
- Weakness: CWE-639
Description
The Wallet System for WooCommerce WordPress plugin before 2.8.0 does not verify that the user submitting a wallet transfer owns the wallet being debited, allowing any authenticated user, including one with only the Subscriber role, to move an arbitrary user's wallet balance, including an administrator's, into an account they control.
Affected products
- Wallet System for WooCommerce: from 2.0.0 before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: Wallet System for WooCommerce 2.8.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-94245 or the next vulnerability affects your stack