What’s Vulnerable › Vulnerabilities
CVE-2026-94246: Wallet System for WooCommerce 2.0.0 - 2.7.10 - Subscriber+ Forged Wallet Withdrawal Request via IDOR
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-08
- Weakness: CWE-639
Description
The Wallet System for WooCommerce WordPress plugin before 2.8.0 does not verify that the wallet account named in a withdrawal submission belongs to the user making it, allowing any authenticated user, such as a subscriber, to file a withdrawal request against another user's wallet for an amount and a payout destination of their choosing, and to indefinitely prevent that user from submitting withdrawals of their own.
Affected products
- Wallet System for WooCommerce: from 2.0.0 before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: Wallet System for WooCommerce 2.8.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-94246 or the next vulnerability affects your stack