What’s Vulnerable › Vulnerabilities
CVE-2026-94250: Apache APISIX: Batch response aggregation can exhaust worker memory
- Severity: high (CVSS 8.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-01
- Weakness: CWE-770
Description
Allocation of resources without limits or throttling vulnerability in batch-requests plugin in Apache APISIX. An unauthenticated caller can drive a gateway worker into OOM via a route where the batch-requests plugin is used and the batch endpoint is publicly exposed. This issue affects Apache APISIX: from 1.3.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache APISIX: from 1.3.0 through 3.18.0
References
- https://lists.apache.org/thread.html/l7o9w8pw3w3f12vf9ybm7xtfzoo6qct4
- http://www.openwall.com/lists/oss-security/2026/10/01/6
Get alerted when CVE-2026-94250 or the next vulnerability affects your stack