What’s Vulnerable › Vulnerabilities
CVE-2026-94267: Advanced Custom Fields: Extended < 0.9.2.8 - Unauthenticated RCE via Front-End Post Update Action
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-23 · updated 2026-10-23
- Weakness: CWE-94
Description
The Advanced Custom Fields: Extended WordPress plugin before 0.9.2.8, Advanced Custom Fields: Extended PRO WordPress plugin before 0.9.2.8 does not perform any capability check when updating a post through one of its front-end form actions, allowing unauthenticated visitors to overwrite arbitrary posts, including the ones in which the site stores its own field definitions, which in turn leads to arbitrary code execution on the server. Exploitation requires the site to publish a form whose post-update action maps both its target and its content to visitor-submitted values.
Affected products
- Advanced Custom Fields: Extended: before 0.9.2.8 — fixed in 0.9.2.8
- Advanced Custom Fields: Extended PRO: before 0.9.2.8 — fixed in 0.9.2.8
How to fix
Upgrade to a fixed version: Advanced Custom Fields: Extended 0.9.2.8; Advanced Custom Fields: Extended PRO 0.9.2.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-94267 or the next vulnerability affects your stack