What’s Vulnerable › Vulnerabilities
CVE-2026-94269: Apache APISIX: Servlet-style normalization creates a route/upstream authorization mismatch
- Severity: medium (CVSS 6.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-01
- Weakness: CWE-647
Description
Use of Non-Canonical URL paths for authorization decisions vulnerability in Apache APISIX. In some configurations where a permissive route overlaps a protected one, a crafted encoded path can reach an upstream endpoint that the matched route's policies were never meant to cover. A request that should have been rejected is served instead, giving unauthenticated access to a protected upstream endpoint. This issue affects Apache APISIX: from 2.14.1 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache APISIX: from 2.14.1 through 3.18.0
References
- https://lists.apache.org/thread.html/6p7glm8jtkjrn12t7z2ybn6bplm22tns
- http://www.openwall.com/lists/oss-security/2026/10/01/7
Get alerted when CVE-2026-94269 or the next vulnerability affects your stack