What’s Vulnerable › Vulnerabilities
CVE-2026-94272: Snap Finance 1.0.8 - 3.11.0 - Unauthenticated Arbitrary Order Status Change via Multiple AJAX Actions
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-19 · updated 2026-10-19
- Weakness: CWE-862
Description
The Snap Finance WordPress plugin before 3.12.0 does not verify that a request to change a WooCommerce order's status comes from an authorised source, allowing unauthenticated attackers to move any order into a paid state or force it to fail.
Affected products
- Snap Finance: from 1.0.8 before 3.12.0 — fixed in 3.12.0
How to fix
Upgrade to a fixed version: Snap Finance 3.12.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-94272 or the next vulnerability affects your stack