What’s Vulnerable › Vulnerabilities
CVE-2026-94276: Apache APISIX: Openid-connect introspection validation issue
- Severity: medium (CVSS 5.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-01
- Weakness: CWE-287
Description
Improper Authentication vulnerability in Apache APISIX. On a route using openid-connect plugin with remote introspection against an authorization server that serves multiple issuers, a token that introspects as active for one issuer may get accepted on a route restricted to another. This issue affects Apache APISIX: from 3.12.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache APISIX: from 3.12.0 through 3.18.0
References
- https://lists.apache.org/thread.html/txn3br25kl657fh15rwcy1oht1xbpyyk
- http://www.openwall.com/lists/oss-security/2026/10/01/8
Get alerted when CVE-2026-94276 or the next vulnerability affects your stack