What’s Vulnerable › Vulnerabilities
CVE-2026-94287: Denial of service via unsigned underflow in libXpm's write path
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-28 · updated 2026-09-29
- Weakness: CWE-1050
Description
A denial of service via unsigned underflow in libXpm's write path in libXpm before 3.5.19 could be used by local attackers to cause unbounded CPU usage and memory exhaustion.
Affected products
- libXpm: before 3.5.19 — fixed in 3.5.19
How to fix
Upgrade to a fixed version: libXpm 3.5.19. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-94287 or the next vulnerability affects your stack