What’s Vulnerable › Vulnerabilities
CVE-2026-94298: BuildKit < 1.0.29 - Contributor+ Stored SQLi via list_content Parameter
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-02 · updated 2026-10-02
- Weakness: CWE-89
Description
The BuildKit WordPress plugin before 1.0.29 does not properly sanitise and escape data submitted by contributor-level users before storing it and later using it in a SQL query, allowing a Contributor to inject SQL that runs against the database once the resulting content is published and viewed by any unauthenticated visitor.
Affected products
- BuildKit: before 1.0.29 — fixed in 1.0.29
How to fix
Upgrade to a fixed version: BuildKit 1.0.29. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-94298 or the next vulnerability affects your stack