What’s Vulnerable › Vulnerabilities
CVE-2026-94373: MISP DOM-based Cross-Site Scripting via innerHTML in Contextual Menu
- Severity: medium (CVSS 6.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-21 · updated 2026-09-21
- Weakness: CWE-79
Description
MISP contains a DOM-based cross-site scripting (XSS) vulnerability in the contextual menu JavaScript component. The ContextualMenu class populates HTML <option> elements by assigning user-controllable values to the innerHTML property. Because innerHTML parses and renders HTML markup, any untrusted string supplied as the option text (value.text or value) is interpreted as live DOM content rather than plain text. An attacker who can influence the data rendered in the contextual menu can inject arbitrary HTML or JavaScript that executes in the victim's browser within the MISP application origin. This may allow session hijacking, data exfiltration, or unauthorized actions performed on behalf of the authenticated user. Version affected: <2.5.47
Affected products
- MISP: before 2.5.47 — fixed in 2.5.47
How to fix
Upgrade to a fixed version: MISP 2.5.47. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-94373 or the next vulnerability affects your stack