What’s Vulnerable › Vulnerabilities
CVE-2026-94382: Beszel before 0.19.0 Insecure Direct Object Reference via user-alerts
- Severity: medium (CVSS 4.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-21 · updated 2026-09-23
- Weakness: CWE-639
Description
Beszel before 0.19.0 contains an insecure direct object reference vulnerability in the POST and DELETE /api/beszel/user-alerts handlers that allows any authenticated user to create or delete alerts on systems they cannot access. Attackers can supply arbitrary system IDs in the request body to register alert rules and receive notifications disclosing target system names and metrics.
Affected products
- henrygd beszel: before 0.19.0 — fixed in 0.19.0
How to fix
Upgrade to a fixed version: henrygd beszel 0.19.0. Check the vendor advisory for mitigations.
References
- https://github.com/henrygd/beszel
- https://github.com/henrygd/beszel/blob/v0.18.8/internal/alerts/alerts_api.go#L19-L80
- https://github.com/henrygd/beszel/commit/6f92b9396dfbacaf71c20444d175af78e0517409
- https://github.com/henrygd/beszel/releases/tag/v0.19.0
- https://github.com/henrygd/beszel/security/advisories/GHSA-759g-ch5m-2gch
- https://www.vulncheck.com/advisories/beszel-before-0.19.0-insecure-direct-object-reference-via-user-alerts
- https://github.com/henrygd/beszel/security/advisories/GHSA-759g-ch5m-2gch
Get alerted when CVE-2026-94382 or the next vulnerability affects your stack