What’s Vulnerable › Vulnerabilities
CVE-2026-94482: Next.js: Denial of Service in App Router using Server Actions
- Severity: high (CVSS 8.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-30
- Weakness: CWE-770
Description
Next.js is a React framework for building full-stack web applications. From 13.0.0 until 15.5.28 and 16.4.1, crafted requests targeting App Router applications with at least one Server Action can cause excessive CPU consumption and block processing of further requests in the same process. Applications using the Pages Router and App Router applications without Server Actions are not affected. This issue is fixed in versions 15.5.28 and 16.4.1.
Affected products
- Npm Next: from 13.0.0 before 15.5.28; from 16.0.0 before 16.4.1 — fixed in 15.5.28, 16.4.1
- Next.js: from 13.0.0, < 15.5.28; from 16.0.0, < 16.4.1
How to fix
Upgrade to a fixed version: Npm Next 15.5.28, 16.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/releases/tag/v15.5.28
- https://github.com/vercel/next.js/releases/tag/v16.4.1
- https://github.com/vercel/next.js/security/advisories/GHSA-p3m5-59mp-jv5r
Get alerted when CVE-2026-94482 or the next vulnerability affects your stack