What’s Vulnerable › Vulnerabilities
CVE-2026-94572
- Severity: critical (CVSS 9.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-21 · updated 2026-09-24
- Weakness: CWE-94
Description
In OpenStack Octavia before 18.0.1, the Amphora provider driver did not validate the listener and pool tls_ciphers field for control characters. The value is written verbatim into the HAProxy configuration generated on the amphora, and thus an authenticated project member who owns a TLS-enabled load balancer can embed a newline and inject arbitrary HAProxy configuration directives. Only deployments using the Amphora provider are affected.
Affected products
- OpenStack Octavia: from 6.0.0 before 16.1.0; from 17.0.0 before 17.0.1; from 18.0.0 before 18.0.1 — fixed in 16.1.0, 17.0.1, 18.0.1
How to fix
Upgrade to a fixed version: OpenStack Octavia 16.1.0, 17.0.1, 18.0.1. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/1148175
- https://bugs.launchpad.net/octavia/+bug/2162101
- https://bugs.launchpad.net/octavia/+bug/2167565
- https://opendev.org/openstack/octavia/commit/cad62902e4984a46ad80cbfa943e90006d8d599d
- https://openwall.com/lists/oss-security/2026/09/21/6
- https://security.openstack.org/ossa/OSSA-2026-039.html
- https://bugs.launchpad.net/octavia/+bug/2162101
Get alerted when CVE-2026-94572 or the next vulnerability affects your stack