What’s Vulnerable › Vulnerabilities
CVE-2026-94579
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-14
- Weakness: CWE-78
Description
An OS command injection vulnerability exists in the PAM (Pluggable Authentication Module) session cleanup routines during SSH session termination on Brocade Fabric OS versions before 9.2.2d and 10.0.0 through 10.0.0a1. An authenticated user authenticating via an external directory or AAA service whose username or profile identifier contains shell metacharacters can trigger arbitrary command execution with root privileges when their remote SSH session closes.
Affected products
- Brocade Fabric OS: before 9.2.2d; from 10.0.0 before 10.0.1 — fixed in 10.0.1, 9.2.2d
How to fix
Upgrade to a fixed version: Brocade Fabric OS 10.0.1, 9.2.2d. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-94579 or the next vulnerability affects your stack