What’s Vulnerable › Vulnerabilities
CVE-2026-94588
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-21 · updated 2026-09-24
- Weakness: CWE-88
Description
In Proxmox pmg-api, an argument injection vulnerability exists in the package changelog retrieval functionality. This is caused by improper handling of user-supplied input passed to the underlying apt-get command when fetching package changelogs. It requires authentication but can be exploited in a CSRF-style attack.
Affected products
- Proxmox pmg-api: from 9.0.0 before 9.0.3 — fixed in 9.0.3
How to fix
Upgrade to a fixed version: Proxmox pmg-api 9.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-94588 or the next vulnerability affects your stack