What’s Vulnerable › Vulnerabilities
CVE-2026-94609: authentik: Privilege Escalation to Superuser via Group Hierarchy
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-24 · updated 2026-09-28
- Weakness: CWE-269
Description
authentik is an open-source identity provider. Prior to 2026.2.7, 2026.5.7, and 2026.8.2, an account with delegated permission to manage a group, group membership, or a user can grant superuser status to an account or assign an existing role to a group without holding the permissions that gate those privileges. Group hierarchy checks do not consistently account for superuser status inherited from ancestor groups, and role assignment to a group lacks the required authorization check. Only deployments that delegate these management capabilities to accounts that are not full administrators are affected. This issue is fixed in versions 2026.2.7, 2026.5.7, and 2026.8.2.
Affected products
- goauthentik authentik: before 2026.2.7; from 2026.5.0, < 2026.5.7; from 2026.8.0, < 2026.8.2
References
- https://docs.goauthentik.io/releases/2026.2#fixed-in-202627
- https://docs.goauthentik.io/releases/2026.5#fixed-in-202657
- https://docs.goauthentik.io/releases/2026.8#fixed-in-202682
- https://github.com/goauthentik/authentik/commit/5f95b86f6f70c3bd8c625a4f9ae474e235f84030
- https://github.com/goauthentik/authentik/commit/67317f66f1b7eb16f2a26bf550dfd73699d49d87
- https://github.com/goauthentik/authentik/commit/67e470dde8c81a40ee27ec6e178462368c561a60
- https://github.com/goauthentik/authentik/commit/898e4e4fa070642a3541a376af0de64fe3ffeb67
- https://github.com/goauthentik/authentik/pull/25956
- https://github.com/goauthentik/authentik/pull/25961
- https://github.com/goauthentik/authentik/pull/25966
- https://github.com/goauthentik/authentik/pull/25971
- https://github.com/goauthentik/authentik/releases/tag/version/2026.2.7
Get alerted when CVE-2026-94609 or the next vulnerability affects your stack