What’s Vulnerable › Vulnerabilities
CVE-2026-94613: authentik: Denial of Service via Document Type Declarations in SAML Messages
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-24 · updated 2026-09-29
- Weakness: CWE-770
Description
authentik is an open-source identity provider. Prior to 2026.2.7, 2026.5.7, and 2026.8.2, an unauthenticated attacker can submit a malformed SAML message to an authentik deployment using SAML in either the identity-provider or SAML source role. The message can stop the worker handling /application/saml/* or /source/saml/*, causing the requests assigned to that worker to fail. Worker process termination and automatic restart do not destroy database-backed sessions, but continued malicious messages can cause a sustained share of legitimate traffic to fail. Other protocol implementations are not affected. This issue is fixed in versions 2026.2.7, 2026.5.7, and 2026.8.2.
Affected products
- goauthentik authentik: before 2026.2.7; from 2026.5.0, < 2026.5.7; from 2026.8.0, < 2026.8.2
References
- https://docs.goauthentik.io/releases/2026.2#fixed-in-202627
- https://docs.goauthentik.io/releases/2026.5#fixed-in-202657
- https://docs.goauthentik.io/releases/2026.8#fixed-in-202682
- https://github.com/goauthentik/authentik/commit/03d19d63b8d8dd7bc3de7cf6e57c6df341a9fc86
- https://github.com/goauthentik/authentik/commit/4cf2f803b1c2ef38c224eead375fd057a10ee8ac
- https://github.com/goauthentik/authentik/commit/732adad26bb97361b6bf25ef138df5c16471ba1f
- https://github.com/goauthentik/authentik/commit/a029f5372295bfeb1e334855f78601681cdc9a2d
- https://github.com/goauthentik/authentik/pull/25959
- https://github.com/goauthentik/authentik/pull/25964
- https://github.com/goauthentik/authentik/pull/25969
- https://github.com/goauthentik/authentik/pull/25974
- https://github.com/goauthentik/authentik/releases/tag/version/2026.2.7
Get alerted when CVE-2026-94613 or the next vulnerability affects your stack