What’s Vulnerable › Vulnerabilities
CVE-2026-94646: Apache Thrift: Node.js `server.js` ends the process on any per-connection error (+ two triggers)
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-02 · updated 2026-10-02
- Weakness: CWE-248
Description
Uncaught exception, Improper validation of specified quantity in input, Improperly controlled modification of object prototype attributes ('prototype pollution') vulnerability in Apache Thrift nodejs bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Thrift: before 0.25.0 — fixed in 0.25.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Thrift 0.25.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/33otcgbqd27wf6qq810q56znzbomnhg1
- https://lists.apache.org/thread/5hjh0gz8wf6bo7ydxjpqj92m42hwmfo8
Get alerted when CVE-2026-94646 or the next vulnerability affects your stack