What’s Vulnerable › Vulnerabilities
CVE-2026-9495
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-26 · updated 2026-07-23
- Weakness: CWE-284
Description
Versions of the package @koa/router from 14.0.0 and before 15.0.0 are vulnerable to Access Control Bypass due to the middleware being silently dropped from the execution chain when the router prefix contains path parameters. Depending on what the skipped middleware was supposed to protect, an attacker could bypass authentication and authorization, evade rate limiting or bypass input sanitization.
Affected products
- @koa/router: from 14.0.0 before 15.0.0 — fixed in 15.0.0
How to fix
Upgrade to a fixed version: @koa/router 15.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/koajs/router/commit/d53e17f284557b1f417946f9807ee52290c3c759
- https://github.com/koajs/router/issues/202
- https://github.com/koajs/router/pull/206
- https://security.snyk.io/vuln/SNYK-JS-KOAROUTER-12215044
- https://github.com/koajs/router/pull/206
Get alerted when CVE-2026-9495 or the next vulnerability affects your stack