What’s Vulnerable › Vulnerabilities
CVE-2026-95101: NGINX ngx_http_v3_module vulnerability
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-15
- Weakness: CWE-172
Description
Description NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_v3_module module. When using HTTP/3 with proxy_request_buffering on directive, an unauthenticated attacker may be able to inject data in the proxied request. Impact This vulnerability may allow remote attackers to inject data in the proxied request. There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Open Source: from 1.31.0 before 1.31.7; from 1.30.0 before 1.30.6; from 1.25.0 — fixed in 1.30.6, 1.31.7
- F5 NGINX Plus: from 37.1.0 before 37.2.0.1; from 37.0.0 before 37.0.7.1; from R36; from R35; from R34; from R33 — fixed in 37.0.7.1, 37.2.0.1
How to fix
Upgrade to a fixed version: F5 NGINX Open Source 1.30.6, 1.31.7; F5 NGINX Plus 37.0.7.1, 37.2.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-95101 or the next vulnerability affects your stack