What’s Vulnerable › Vulnerabilities
CVE-2026-95616: Apache WSS4J: Unauthenticated denial of service via integer overflow in DER parsing of X.509 certificate extensions
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-30 · updated 2026-10-06
- Weakness: CWE-190
Description
An integer overflow in WSS4J's DER bounds check lets an oversized allocation pass validation. An unauthenticated attacker can send a SOAP message carrying an X.509 certificate whose SubjectKeyIdentifier extension declares a length of 0x7FFFFFFF; WSS4J decodes this while resolving the signature's key reference, before the message is authenticated, so an eleven-byte extension triggers a 2 GB allocation. Repeated requests exhaust server memory. Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.
Affected products
- Apache Software Foundation Apache WSS4J: before 2.4.4; from 3.0.0 before 3.0.6; from 4.0.0 before 4.0.2 — fixed in 2.4.4, 3.0.6, 4.0.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache WSS4J 2.4.4, 3.0.6, 4.0.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/sdf0fsphkg4qbj7nh2brjgwvcmd67hct
- http://www.openwall.com/lists/oss-security/2026/09/30/14
Get alerted when CVE-2026-95616 or the next vulnerability affects your stack