What’s Vulnerable › Vulnerabilities
CVE-2026-95620: Use-after-free vulnerability in QNetworkAccessManager HTTP/2 support impacts Qt
- Severity: low (CVSS 2.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-23 · updated 2026-10-23
- Weakness: CWE-416
Description
A use-after-free vulnerability in the Qt QNetworkAccessManager HTTP/2 client support of the Qt Network module allows a malicious or compromised HTTP/2 server to cause the client application to crash, affecting availability.
Affected products
- Qt: from 6.9.0 before 6.11.3 — fixed in 6.11.3
How to fix
Upgrade to a fixed version: Qt 6.11.3. Check the vendor advisory for mitigations.
References
- https://codereview.qt-project.org/c/qt/qtbase/+/759717
- https://wiki.qt.io/List_of_known_vulnerabilities_in_Qt_products#CVE-2026-95620:
Get alerted when CVE-2026-95620 or the next vulnerability affects your stack