What’s Vulnerable › Vulnerabilities
CVE-2026-95624: Tauri framework v2 malicious downgrade via allow_downgrades from frontend code
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-22 · updated 2026-09-22
- Weakness: CWE-284
Description
The Tauri updater plugin's 'check' IPC command accepts an allowDowngrades boolean parameter directly from frontend JavaScript code. When set to true, it replaces the version comparator from "update must be newer" to "update must be different." Because the default permission set grants allow-check to the webview, any XSS in the app frontend can invoke this command and bypass the only anti-rollback protection the updater offers. Combined with another bug, this enables downgrade attacks without even needing to fake a higher version number.
Affected products
- tauri-plugin-updater: from 2.8.0 before 2.12.0 — fixed in 2.12.0
How to fix
Upgrade to a fixed version: tauri-plugin-updater 2.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/tauri-apps/plugins-workspace/commit/1308bfa399b962b3977c767100a6339d1cbfdd20
- https://github.com/tauri-apps/plugins-workspace/releases/tag/updater-v2.12.0
- https://github.com/tauri-apps/tauri
- https://github.com/tauri-apps/tauri/security/advisories/GHSA-rjc6-5hfg-grp9
Get alerted when CVE-2026-95624 or the next vulnerability affects your stack