What’s Vulnerable › Vulnerabilities
CVE-2026-95625: Tauri framework v2 missing updater signature version number validation can be exploited into forced downgrade
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-09-23
- Weakness: CWE-354
Description
The Tauri updater plugin verifies update binaries using minisign signatures, but the signature covers only the raw binary bytes. The update manifest -- which contains the version number, download URL, and signature -- is fetched over TLS but is never itself signed or authenticated. Because the only anti-rollback check compares the manifest's version field against the current version, and that field is unsigned, an attacker who can serve a crafted manifest can force installation of any older signed release without possessing the developer's private key.
Affected products
- tauri-plugin-updater: from 2.0.0 before 2.12.0; from 2.12.0 — fixed in 2.12.0
How to fix
Upgrade to a fixed version: tauri-plugin-updater 2.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/tauri-apps/plugins-workspace
- https://github.com/tauri-apps/plugins-workspace/commit/690dcfd694
- https://github.com/tauri-apps/plugins-workspace/releases/tag/updater-v2.12.0
- https://github.com/tauri-apps/plugins-workspace/security/advisories/GHSA-j38x-g3m3-95fr
Get alerted when CVE-2026-95625 or the next vulnerability affects your stack