What’s Vulnerable › Vulnerabilities
CVE-2026-9570: Taskbuilder < 5.0.8 - Reflected XSS via Shortcode
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Taskbuilder WordPress plugin before 5.0.8 does not properly sanitise a URL parameter before echoing it into inline JavaScript on a frontend page containing one of its shortcodes, leading to a Reflected Cross-Site Scripting vulnerability that can be triggered against any logged-in user.
Affected products
- Taskbuilder: before 5.0.8 — fixed in 5.0.8
How to fix
Upgrade to a fixed version: Taskbuilder 5.0.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-9570 or the next vulnerability affects your stack