What’s Vulnerable › Vulnerabilities
CVE-2026-95818: AT_SECURE program buffer overflow via $ORIGIN processing
- Severity: low (CVSS 3.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-22 · updated 2026-09-22
- Weakness: CWE-121
Description
A stack-based buffer overflow in the dynamic loader (ld.so) of the GNU C Library (glibc) versions 2.14 through 2.44 allows a local attacker to crash or corrupt the memory of setuid/setgid (AT_SECURE) programs. When such a program's DT_RPATH or DT_RUNPATH begins with $ORIGIN and is followed by NUL or '/' the loader both reads past the end of the path buffer and writes past the end of a stack-allocated internal buffer. The corrupted loader stack can lead to a loader crash (denial of service) and limited disclosure of process memory.
Affected products
- GNU C Library (glibc): from 2.14 before 2.45 — fixed in 2.45
How to fix
Upgrade to a fixed version: GNU C Library (glibc) 2.45. Check the vendor advisory for mitigations.
References
- https://sourceware.org/bugzilla/show_bug.cgi?id=34360
- https://sourceware.org/git/?p=glibc.git;a=blob_plain;f=advisories/GLIBC-SA-2026-0023
Get alerted when CVE-2026-95818 or the next vulnerability affects your stack