What’s Vulnerable › Vulnerabilities
CVE-2026-95837: containerd CRI plugin: Checkpoint restore bypasses destination security context
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-16
- Weakness: CWE-269
Description
containerd is an open-source container runtime. From 2.1.0 until 2.2.7 and 2.3.4, containerd's CRI CreateContainer checkpoint restore is vulnerable because CRIU restores process security state from checkpoint data instead of enforcing the destination ContainerConfig. An attacker who can create a container from a crafted checkpoint can supply restored credentials, capabilities, no_new_privs, and seccomp state. The restored process can run as root with full capabilities and no enforced seccomp filters while CRI status reports the requested configuration. Systems that do not use CRI checkpoint restore are not affected. This issue is fixed in versions 2.2.7 and 2.3.4.
Affected products
- containerd: from 2.1.0, < 2.2.7; from 2.3.0, < 2.3.4
References
- https://github.com/containerd/containerd/commit/928c03c6898cad95f795300281fdff0dbc55a32f
- https://github.com/containerd/containerd/pull/13913
- https://github.com/containerd/containerd/security/advisories/GHSA-p7v4-vr35-mj6f
Get alerted when CVE-2026-95837 or the next vulnerability affects your stack