What’s Vulnerable › Vulnerabilities
CVE-2026-96251: Microsoft PowerShell Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-13 · updated 2026-10-31
- Weakness: CWE-807
Description
Reliance on untrusted inputs in a security decision in Microsoft PowerShell allows an unauthorized attacker to execute code over a network.
Affected products
- Microsoft Powershell: from 7.4 before 7.4.21; from 7.5 before 7.5.12; from 7.6 before 7.6.7 — fixed in 7.4.21, 7.5.12, 7.6.7
- Microsoft PowerShell 7.4: from 7.4.0 before 7.4.21 — fixed in 7.4.21
- Microsoft PowerShell 7.5: from 7.5.0 before 7.5.12 — fixed in 7.5.12
- Microsoft PowerShell 7.6: from 7.6.0 before 7.6.8 — fixed in 7.6.8
How to fix
Upgrade to a fixed version: Microsoft Powershell 7.4.21, 7.5.12, 7.6.7; Microsoft PowerShell 7.4 7.4.21; Microsoft PowerShell 7.5 7.5.12; Microsoft PowerShell 7.6 7.6.8. Check the vendor advisory for mitigations.
In the news
References
Get alerted when CVE-2026-96251 or the next vulnerability affects your stack