What’s Vulnerable › Vulnerabilities

CVE-2026-96259: Mattermost server-side request forgery via OAuth endpoints configurable by a System Administrator

Description

Mattermost versions 11.9.x <= 11.9.1, 11.8.x <= 11.8.5, 11.7.x <= 11.7.10, 11.10.x <= 11.10.1 fail to apply the internal-connection filter to OAuth endpoint requests, which allows a System Administrator to make the server issue requests to internal network addresses and read the responses via the configured OAuth token and userinfo endpoints.. Mattermost Advisory ID: MMSA-2026-00776

Affected products

How to fix

Upgrade to a fixed version: Mattermost 11.10.2, 11.7.11, 11.8.6, 11.9.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-96259 or the next vulnerability affects your stack