What’s Vulnerable › Vulnerabilities
CVE-2026-9640: LXD Snapshot Import Privilege Escalation Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-26 · updated 2026-10-25
- Weakness: CWE-863
Description
A privilege escalation vulnerability exists in LXD from 6.0 before 6.9, 5.21.0 before 5.21.5, and 5.0.0 before 5.0.7 regarding the handling of project-restriction policies during snapshot restoration.. An authenticated project operator in a restricted multi-tenant environment can bypass policy restrictions by importing a maliciously crafted instance backup containing restricted configuration keys within a snapshot. When the snapshot is restored, these restricted keys are applied to the live instance without policy validation. Starting the modified instance grants the operator unauthorized host root access.
Affected products
- Canonical LXD: from 4.12 before 5.0.7; from 5.21.0 before 5.21.5; from 6.0 before 6.9 — fixed in 5.0.7, 5.21.5, 6.9
How to fix
Upgrade to a fixed version: Canonical LXD 5.0.7, 5.21.5, 6.9. Check the vendor advisory for mitigations.
References
- https://github.com/canonical/lxd/pull/18301
- https://github.com/canonical/lxd/pull/18303
- https://github.com/canonical/lxd/pull/18304
- https://github.com/canonical/lxd/security/advisories/GHSA-ppq7-4492-5552
- https://github.com/canonical/lxd/security/advisories/GHSA-ppq7-4492-5552
Get alerted when CVE-2026-9640 or the next vulnerability affects your stack