What’s Vulnerable › Vulnerabilities
CVE-2026-96419: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in Wireshark
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-29 · updated 2026-10-08
- Weakness: CWE-22
Description
Profile import crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service and possible code execution
Affected products
- Wireshark Foundation Wireshark: from 4.4.0 before 4.4.19; from 4.6.0 before 4.6.9 — fixed in 4.4.19, 4.6.9
How to fix
Upgrade to a fixed version: Wireshark Foundation Wireshark 4.4.19, 4.6.9. Check the vendor advisory for mitigations.
References
- https://gitlab.com/wireshark/wireshark/-/work_items/21553
- https://www.wireshark.org/security/wnpa-sec-2026-106.html
- https://gitlab.com/wireshark/wireshark/-/work_items/21553
Get alerted when CVE-2026-96419 or the next vulnerability affects your stack