What’s Vulnerable › Vulnerabilities

CVE-2026-96442: Emacs: emacs: arbitrary code execution in flymake mode

Description

A code execution flaw was found in Emacs, affecting versions prior to 31.2. The Flymake mode using language backends other than Lisp would execute arbitrary code from the edited file while performing syntax checking. Viewing or editing untrusted files using Emacs could lead to arbitrary code execution with the privileges of the user running Emacs.

Affected products

How to fix

Upgrade to a fixed version: GNU Emacs 31.2; Red Hat Enterprise Linux 10 1:29.4-14.el10_2.3; Red Hat Enterprise Linux 8 1:26.1-15.el8_10.4; Red Hat Enterprise Linux 9 1:27.2-18.el9_8.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-96442 or the next vulnerability affects your stack