What’s Vulnerable › Vulnerabilities
CVE-2026-96524: MCP Server for WordPress < 1.8.2 - Administrator Account Creation via CSRF
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-26 · updated 2026-09-28
- Weakness: CWE-352
Description
The MCP Server for WordPress WordPress plugin before 1.8.2 does not correctly verify the WordPress REST API nonce for cookie-authenticated requests when a condition an attacker can influence is present, allowing unauthenticated attackers to perform administrator-only actions, including creating a new administrator account, by tricking a logged-in administrator into visiting a crafted page.
Affected products
- MCP Server for WordPress: before 1.8.2 — fixed in 1.8.2
How to fix
Upgrade to a fixed version: MCP Server for WordPress 1.8.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-96524 or the next vulnerability affects your stack