What’s Vulnerable › Vulnerabilities
CVE-2026-96531: Optimole 4.0.0 - 4.2.12 - Author+ Stored XSS via Video Player Block
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-26 · updated 2026-09-28
- Weakness: CWE-79
Description
The Optimole WordPress plugin before 4.2.13 does not escape unrecognized attributes of its video-player block before rendering them onto the block's wrapper element, allowing users with the Author role and above to store an event-handler attribute that executes scripts in the browser of any user, such as an administrator, who views the post.
Affected products
- Optimole: from 4.0.0 before 4.2.13 — fixed in 4.2.13
How to fix
Upgrade to a fixed version: Optimole 4.2.13. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-96531 or the next vulnerability affects your stack