What’s Vulnerable › Vulnerabilities
CVE-2026-9658: Plack::Middleware::Security::Common versions before 0.13.1 for Perl did not block header injections in request paths
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-28 · updated 2026-10-26
- Weakness: CWE-113
Description
Plack::Middleware::Security::Common versions before 0.13.1 for Perl did not block header injections in request paths. The header injection rule was ineffective at blocking header injections in the request paths unless they were double-encoded, for example, GET /path\r\nHTTP/1.1\r\nHost: secret.example.com Note that it is unclear whether request paths with CRLF followed by additional headers would be blocked by reverse proxies, or how they would be processed by Plack-based servers.
Affected products
- RRWO Plack::Middleware::Security::Common: before 0.13.1 — fixed in 0.13.1
How to fix
Upgrade to a fixed version: RRWO Plack::Middleware::Security::Common 0.13.1. Check the vendor advisory for mitigations.
References
- https://metacpan.org/release/RRWO/Plack-Middleware-Security-Simple-v0.13.1/changes
- http://www.openwall.com/lists/oss-security/2026/05/28/9
Get alerted when CVE-2026-9658 or the next vulnerability affects your stack