What’s Vulnerable › Vulnerabilities
CVE-2026-96615: NGINX Gateway Fabric vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-15
- Weakness: CWE-290
Description
Description NGINX Gateway Fabric has a vulnerability when it is configured with Gateway Custom Resource Definition (CRD) and have an authenticated gRPC connection with NGINX Agent. A namespaced authenticated attacker with access to a service account may impersonate the authenticated NGINX Agent gRPC connection to read TLS private keys of Gateway deployments in another namespace. Impact A remote authenticated attacker may be able to read TLS private keys of Gateway deployments in another namespace. There is no data plane exposure; this is a control plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Gateway Fabric: from 2.0.0 before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: F5 NGINX Gateway Fabric 2.8.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-96615 or the next vulnerability affects your stack